Skip Navigation LinksForums > Integrations & Plug-Ins > Bug Tracker Data-Sync Int... > Unable to get Jira and Sp...

Unable to get Jira and SpiraTest to communicate over SSL RSS Feed

Tuesday, May 10, 2011

I have followed the set up guide for the integration between SpiraTest and Jira 4.2.4. However I am unable to get the systems to communicate. Exception found in Windows event view is: 

There was no endpoint listening at that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details.

Server stack trace: 
   at System.ServiceModel.Channels.HttpOutput.WebRequestHttpOutput.GetOutputStream()
   at System.ServiceModel.Channels.HttpOutput.Send(TimeSpan timeout)
   at System.ServiceModel.Channels.HttpChannelFactory.HttpRequestChannel.HttpChannelRequest.SendRequest(Message message, TimeSpan timeout)
   at System.ServiceModel.Channels.RequestChannel.Request(Message message, TimeSpan timeout)
   at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
   at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
   at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]: 
   at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
   at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
   at Inflectra.SpiraTest.DataSyncService.SpiraDataSync.IDataSync.Connection_Authenticate(String userName, String password)
   at Inflectra.SpiraTest.DataSyncService.DataSyncService.CheckStatus(Object state)

I have managed to get this to work earlier - then with a test setup were both applications were running on same server without SSL. 

Can SSL be the issue here? I have seen that there are some entries in web.config in regards to datasync, and that has https_get set to false. 

Can you provide some assistance?
2 Replies
Adam SAdam S
re: Ivar S++nstab++ on Tuesday, May 10, 2011
Tuesday, May 10, 2011

If you enter the URL: into a web browser, what appears?

Also what is the normal URL you use for accessing SpiraTest?


Ivar S++nstab++Ivar S++nstab++
re: Adam S on Tuesday, May 10, 2011
Tuesday, May 10, 2011
After a couple of email with support this turned out as the solution: 

in Web.Config, change HttpGetEnabled to false and HttpsGetEnabled to true.

Thanks a bundle!
  • Started: 5/10/2011
  • Last Reply: 5/10/2011
  • Replies: 2
  • Views: 3600
Powered by KronoDesk v1.1.0.15 | © Copyright Inflectra Corporation 2011-2016 | Licensed to Inflectra Corporation.