Can Rapise execute a test on a machine without user logging in?

Wednesday, October 24, 2018
Avatar

I want to schedule my regression test sets from SpiraTest to run them on a Virtual Machine nightly. Right now they don't run unless I log in to the machine and have the screen open.

Can I schedule some tests to run by itself nightly without a user logging in?

If not, what are my options? It doesn't make sense to me to develop automation tests but then have to manually execute them. 

5 Replies
Friday, October 26, 2018
Avatar
re: knguyen_fhlbc Wednesday, October 24, 2018

Hello,

Please take a look at this KB article: https://www.inflectra.com/Support/KnowledgeBase/KB325.aspx

It explains how to more easily keep the VM logged with a specific user.

It needs to be logged so that it can actually perform UI actions against the UI being tested, that is the reason.

It is impossible to do UI testing of applications without a Windows desktop running unfortunately.

Regards

Jim

Tuesday, October 30, 2018
Avatar
re: inflectra.jimx Friday, October 26, 2018

Hi Jim, thank you. I'll take a look at the KB and give it a try.

Tuesday, November 6, 2018
Avatar
re: knguyen_fhlbc Tuesday, October 30, 2018

I setup the bat script and use it to disconnect my remote desktop session, and the tests run fine but only if I just disconnect it, or maybe about 15 minutes. If I disconnect it for about 2 hours or more, the tests fail. One day I left work at 4pm and scheduled the tests to run at 6pm, they failed. The tests that I schedule to run on a weekend also failed because the idle time of course longer than 2 hours.

Do you have any idea how to get around this?

Thanks.

Tuesday, November 20, 2018
Avatar
re: knguyen_fhlbc Tuesday, November 6, 2018

Hi Katie,

 

It appears that you need to tweak MaxDisconnectionTime setting for the VM.

https://superuser.com/questions/994776/session-logged-out-after-disconnection-of-remote-connection

Here is the solution from there:

  1. Start gpedit.msc
  2. Browse to :
    Computer Configuration --> Administrative Templates --> Windows Components --> Remote Desktop Services --> Remote Desktop Session Host --> Session Time Limits.
  3. Enable "Set time limit for disconnected sessions" and set it to Never.
  4. Use regedit to go to the key
    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services
    and ensure that MaxDisconnectionTime is set for the amount of time you want to set as the time limit in milliseconds (12 hours = 43200000). If it does not exist, create it as New DWORD (32-bit). (more info.)
  5. Reboot.
  6. Verify after reboot that the above registry setting has not changed. (In a domain, the domain settings may override local ones.)

If this doesn't work and your server is in a domain, have the IT people check in your OU the setting of "Terminate disconnected session".

Regards,

Alexey

Wednesday, January 23, 2019
Avatar
re: alexey.grinevich Tuesday, November 20, 2018

FYI. This solution didn't work for me either.

Statistics
  • Started: Wednesday, October 24, 2018
  • Last Reply: Wednesday, January 23, 2019
  • Replies: 5
  • Views: 370