Thread

Skip Navigation LinksForums > Rapise Forums > Rapise Issues & Questions > Support for QT?

Support for QT? RSS Feed

Thursday, November 10, 2011
Hi Inflectra,

We are heavily into trialling the Rapise tool but a lot of our in-house and 3rd party applications are written using the QT framework.

We are having terrible trouble recognising any objects in our applications. We have tried all the methods listed in the documentation in addition to no method - and forcing Rapise to learn the object. We are having no success.

Additionally, even the relative analogue record method doesn't work.

Can you please confirm support for QT or add some insight into the issue?

Thanks again,

Roames
9 Replies
Adam SAdam S
re: Nick v on Thursday, November 10, 2011
Thursday, November 10, 2011
We don't have explicit support for the QT framework, so depending on what platform you're running on, it may or may not work. Are these .NET, Java or C++ applications? The custom libraries in Rapise will work as long as QT implements the Microsoft Active Accessibility (MSAA) standard. I have asked our developers to provide more information on whether QT fully supports MSAA, will let you know.
Adam SAdam S
re: Adam S on Thursday, November 10, 2011
Saturday, November 12, 2011

According to our development group, the best choice would be to use the following Rapise libraries:

1. Generic library
2. Advanced accesibility library.

We haven't a specific QT library, but depending on customer demand we may invest in that as an additional library.

If you use these two libraries listed above, does the Learn feature recognize objects in your application. Let us know if not and we can investigate further for you. For more specific advice, you can submit a support ticket to support@inflectra.com

Adam SAdam S
re: Adam S on Saturday, November 12, 2011
Sunday, November 13, 2011

We just tried using Rapise with a sample Qt application:

http://qt-apps.org/content/show.php/QXmlEdit?content=88878

and using both the Generic and Advanced Accessibility libraries together, it was able to recognize the objects.

Nick vNick v
re: Adam S on Sunday, November 13, 2011
Tuesday, November 15, 2011
Hi Rapise,

Thank you so much for your help. We have completed evaluating SpiraTeam and have decided to purchase some copies, so we'll be in touch soon. Our Rapise evaluation will be based on success with QT.

I have tried using the combined generic/advanced libraries and am tentatively increased confidence as the recording dialogue seems to display the object names now - previously this was not happening.

However, I now have a syntax error occurring on playback in the (assumed, based on debugging) player.js script. An initial overview of this class I cannot find a problem with.

The output displays thus:

SeS Player Starting...
Verbose level:1
C:\Program Files (x86)\Inflectra\Rapise\Bin\..\Engine\Player.js(487,2): Expected '}'
Error evaluating script file C:\Users\nick.vandernet\Documents\My Rapise Tests\QT Test 001\QT Test 001.js (syntax error): SyntaxError: Expected '}'
###Initialization error (0)

So, I think we're close, but damn brackets!

Please help.

Roames.
Nick vNick v
re: Nick v on Tuesday, November 15, 2011
Tuesday, November 15, 2011
Hi Inflectra,

We fixed the syntax error - looks like it was caused by an ellipses in an automatic comment.

However, this resulted in the same original problem - on playback no objects are recognised.

Does your library rely on the Microsoft Accessibility metadata being implemented (names of objects and other exposing, etc)?

Because these controls have not been implemented. So I also tried running a quick record-and-play over one of the most common QT apps around - google earth - and found the same problem. Rapise cannot recognise the objects.

Please advise.

Thanks again,

Roames.
Adam SAdam S
re: Nick v on Tuesday, November 15, 2011
Tuesday, November 15, 2011

Nick

The Generic and Advanced Accessibility libraries of Rapise do rely on the MSAA metadata being published correctly by the UI framework (some of the others use different methods, e.g. browser DOM, .NET, Java, etc.).

We shall check into the playback issue and let you know what our recommendations are.

Adam SAdam S
re: Adam S on Tuesday, November 15, 2011
Wednesday, November 16, 2011

Nick

How are the objects being recognized? Are they displayed as Simulted objects in the object tree inside Rapise? You can email your sample Rapise project files as a zip to support@inflectra.com

Thanks!

Nick vNick v
re: Adam S on Wednesday, November 16, 2011
Thursday, November 17, 2011
Hi Rapise,

I have now taken this offline and am working with Adam. I look forward to posting success. Thanks for your help thus far.

Roames
Adam SAdam S
re: Nick v on Thursday, November 17, 2011
Friday, January 27, 2012
We have just released Rapise v1.3.1 that comes with built-in support for testing Qt applications.
Tagged
Statistics
  • Started: 11/10/2011
  • Last Reply: 1/27/2012
  • Replies: 9
  • Views: 853
Powered by KronoDesk v1.1.0.15 | © Copyright Inflectra Corporation 2011-2016 | Licensed to Inflectra Corporation.