Rapise on Android with Appium timeout issue?

Monday, November 7, 2022
Avatar

Hello,

I am running a "long running" test on an android device.  It takes a long time because our android application runs a long time... processing a lot of stuff.  This is as designed.

When I manually run this test on either a physical device or emulator, it runs just fine. I can process stuff along time (hours). Our app stays running indefinitely.  But when I automate this using Rapise with Appium after a while our app just disappears.  It doesn't appear to be crashing. What appears to be happening is that (without there being any failures triggered in the script, Appium is simply closing our application.

Is there some sort of built-in time limit to how long a Rapise script can run?

Appium continues running and connected to the device or emulator. I can restart the test if I want to.  I have tried adjusting every wait and every delay and it doesn't seem to help.  Thoughts?

I had a different test, for a different android application where I discovered that eventually Appium was running out of memory and the test was aborting. But it was easy to tell this was happening by looking at the output in the Appium Console window. That's not what is happening in this scenario. Appium keeps running and no specific Appium errors.

I also tried saving a screenshot on failure, but that doesn't help. I just get a screenshot of my blank Android Desktop screen after the application was closed.

1 Replies
Tuesday, November 8, 2022
Avatar
re: kevmiller Monday, November 7, 2022

Hi Kevin

Please could you log a support ticket.

Thanks
David

Statistics
  • Started: Monday, November 7, 2022
  • Last Reply: Tuesday, November 8, 2022
  • Replies: 1
  • Views: 92