Skip Navigation LinksForums > Rapise Forums > Rapise Issues & Questions > "MozRepl not installed" e...

"MozRepl not installed" error on Firefox Interaction RSS Feed

Monday, January 7, 2013
Hi there,

I've just started using a demo of Rapise for evaluation, and am getting this error whenever I launch FireFox: 

"'MozRepl' Package not installed or not running.  It is required for record/playback in Firefox browser. Press Ok to see Installation guide."

I am using Firefox 17.0.1, and the installed version of MozRepl (acquired from the Inflectra site) is 42.0.0.  I also tried getting a different version of MozRepl, in case that was the issue.  There was a post about this issue in Rapise 1.3, but appeared to have been fixed in 1.3.1?

Any ideas?  Thanks!
3 Replies
Adam SAdam S
re: Yves M Gagnon on Monday, January 7, 2013
Tuesday, January 8, 2013

Hi Yves

Inside Firefox do you have the MozRepl add-in listed as running or disabled?



Yves M GagnonYves M Gagnon
re: Adam S on Tuesday, January 8, 2013
Wednesday, January 9, 2013
MozRepl was listed as installed and active.  I have just had my computer replaced here, however, so I'll go through the process again and see if my new computer gives different results.
Yves M GagnonYves M Gagnon
re: Yves M Gagnon on Wednesday, January 9, 2013
Wednesday, February 6, 2013
I just got back into this, and I'm having similar results.  FireFox 18, MozRepl 42.0.0 installed and active.  When I record and launch FireFox, I'm actually having intermittent results.  Sometimes, the FireFox window launches and the recorder disappears (then I click record again and select the window that was launched, and the recording seems to work, but it does not capture the application launch).  Most of the time, it will launch the FireFox instance, start the recorder, and as soon as I click in the address bar to enter the address, it will report that MozRepl is not installed.  I tried to see if that was just a message showing at the incorrect time, and maybe it would record anyway (since I've seen it record now), but this does not seem to be the case.  (Though I just tried it again, clicked Ok on the notification, and it started recording... got through address entry, then bogged down for five minutes during an attempt to verify a text string onscreen. When the "Verify Object Properties" dialogue came up, it showed "Undefined" for all of the parameters, and cancelling that dialog cancelled the script recording and returned me to a blank "Start Page".)
  • Started: 1/7/2013
  • Last Reply: 2/6/2013
  • Replies: 3
  • Views: 3746
Powered by KronoDesk v1.1.0.15 | © Copyright Inflectra Corporation 2011-2016 | Licensed to Inflectra Corporation.