Test Step in SpiraTeam shows wrong execution status

Friday, May 9, 2014 4:49:47 PM
Hi
I set up an automated test run with TestComplete and logged a screenshot with the following code..

Log.Picture(Sys.Desktop, "Log Picture");

but what returns in SpiraTeam is just a Caution for the Test Step and "!Warning!: Log Picture" for the Console Output. 
Note that Test Case actually passes, so I'm guessing something went wrong went it's reading the TestComplete Log at the test step level.
It's pretty much reporting wrong execution status for all logs(Log.Warning, Log.Checkpoint, Log.Error and so on...) at the Test Step level.

Is this a problem caused by RemoteLaunch or SpiraTeam? Is there a way to configure the settings so that it reports a correct status? Also, is this the reason why there's no screetshots uploaded to SpiraTeam under Attachment? From what I understand from the documentation screenshots should've been captured automatically.

TestComplete Version: 10.0.531.7
RemoteLaunch Version: 4.0

2 Replies
Friday, May 9, 2014 9:08:07 PM
Avatar
re: Jason on Friday, May 9, 2014 4:49:47 PM

Hi Jason

Please can you log a help desk ticket and provide an example screenshot of the log.

Thanks

Adam

Tuesday, May 20, 2014 7:36:20 PM
Avatar
re: inflectra.adam on Friday, May 9, 2014

Based on feedback from SmartBear and the following StackOverflow article: http://stackoverflow.com/questions/10137334/why-does-testcomplete-keep-changing-status-image-name

We have published updated versions of the TestComplete and TestExecute 10.0 plugins on our website:

Regards

Adam

Statistics
  • Started: Friday, May 9, 2014 4:49:47 PM
  • Last Reply: Tuesday, May 20, 2014 7:36:20 PM
  • Replies: 2
  • Views: 3367