Thread

Skip Navigation LinksForums > SpiraTeam Forums > SpiraTeam Issues & Questi... > Deleting Test Cases & Run...

Deleting Test Cases & Runs from Requirement leaves previous results RSS Feed

Wednesday, November 23, 2011
Hi Inflectra,

I have a requirement that had two tests covering it. I had previously executed one of the tests that updated the requirement result in the requirements list. Ok thus far.

I later deleted this test case and the test run it was associated with only to find that not only did the result persist, but the requirement now says it is still covered by a test case that no longer exists.

I see the only workaround as deleting and re-inserting the requirement.

Please help.

Thanks again,

Roames
2 Replies
Adam SAdam S
re: Nick v on Wednesday, November 23, 2011
Wednesday, November 30, 2011
That shouldn't happen, what patch level of SpiraTeam v3.1 are you using? Make sure you have the latest patch (16) applied. If that doesn't fix it, go to Administration > Project History Changes and purge the delete (i.e. makes the soft delete permanent), however this shouldn't be necessary.
Adam SAdam S
re: Adam S on Wednesday, November 30, 2011
Wednesday, November 30, 2011
Oh forgot to mention, if you aren't on patch 16, apply the patch and then click on Administration > Data Tools > Refresh Test Execution Status to force it to update the requirements test status again.
Tagged
Statistics
  • Started: 11/23/2011
  • Last Reply: 11/30/2011
  • Replies: 2
  • Views: 590
Powered by KronoDesk v1.1.0.15 | © Copyright Inflectra Corporation 2011-2016 | Licensed to Inflectra Corporation.