Thread

Skip Navigation LinksForums > SpiraTest Forums > SpiraTest Issues & Questi... > Righit click context menu...

Righit click context menu (delete) is not working if test set is not selected RSS Feed

Wednesday, June 22, 2011
I have several test buckets at the test set page of Spira.
    I have tried to delete one of sets by right click delete menu but whenever do that there is a pop-up says I have to select at least one item.
    When I right click an item and choose delete menu, the checkbox of the item is selected but once I click on 'Yes'  of comfirm window the checkbox is cleared and asking me to choose at least one item.
    NOTE that even if i did not select the checkbox of an item other context menus like 'edit', 'open' are working great.
5 Replies
Adam SAdam S
re: W L on Wednesday, June 22, 2011
Sunday, June 26, 2011
>>> The warning box causes the item to deselect (that's the reason), but we decided to leave it that way to prevent accidental deletes. It's a lower priority, but it may get addressed in a future release.
Oliver GrambergOliver Gramberg
re: Adam S on Sunday, June 26, 2011
Friday, February 26, 2016

>>> The warning box causes the item to deselect (that's the reason), but we decided to leave it that way to prevent accidental deletes

You have the confirmation popup to prevent accidental deletes, so this is not a valid reason to reject/delay a fix. Please bump up the priority!

Regards
Oliver

Elise B.Elise B.
re: Oliver Gramberg on Friday, February 26, 2016
Friday, February 26, 2016
Hi Oliver,

This is an old thread and the bug it refers to was fixed. Are you having a problem deleting test sets with SpiraTest 4.2? Can you describe it step by step?

Thanks!
Elise
Oliver GrambergOliver Gramberg
re: Elise B. on Friday, February 26, 2016
Monday, February 29, 2016

Hi,

we run SpiraTeam v4.2.0.8.

  • In „Testing > Test cases > Test case details“ view, right-click on a test step

    • Expected: check box is checked, context menu is displayed

    • Actual: ditto

  • In context menu, select „Open item“

    • Expected: Selected test step is opened in „Test step details“ view

    • Actual: ditto


  • In „Testing > Test cases > Test case details“ view, right-click on a test step

    • Expected: check box is checked, context menu is displayed

    • Actual: ditto

  • In context menu, select „Delete“

    • Expected: Deletion confirmation popup

    • Actual: ditto

  • Confirm deletion

    • Expected: Selected test step is deleted

    • Actual: popup which says „You need to select at least ONE checkbox for the Delete command!“

Regards

Oliver

Elise B.Elise B.
re: Oliver Gramberg on Monday, February 29, 2016
Monday, February 29, 2016
Thanks for the additional information, Oliver. I understand now. You are right, there is still something that's not working right with deleting in lists. However, it does not happen with all browsers, and there are workarounds. 

The easiest workaround is to manually select the checkbox first, and then right-click. 

Another option is to select one or more checkboxes, and then click on the Delete button.

The problem only seems to happen with Internet Explorer, so if it's feasible for you to use a different browser such as Firefox or Chrome, you won't encounter this issue.

Regards,
Elise
Tagged
Statistics
  • Started: 6/22/2011
  • Last Reply: 2/29/2016
  • Replies: 5
  • Views: 504
Powered by KronoDesk v1.1.0.15 | © Copyright Inflectra Corporation 2011-2016 | Licensed to Inflectra Corporation.