Thread

Skip Navigation LinksForums > SpiraTest Forums > SpiraTest Issues & Questi... > Unable to create new rele...

Unable to create new release with SOAP API v2.2 RSS Feed

Friday, August 26, 2016
I'm facing problem when trying to create a new release using SOAP API v2.2

System.Web.Services.Protocols.SoapException: Release object needs to have ReleaseId set to null for creation
  at Inflectra.SpiraTest.Web.Services.v2_2.ImportExport.Release_Create(RemoteRelease remoteRelease, Nullable `1 parentReleaseId)

in the request I've set <releaseId>0</releaseId>.... Tried also -1 but no help (same error). If I leave it empty I get 'Input string was not in a correct format' error.
1 Replies
Joni VanhamakiJoni Vanhamaki
re: Joni Vanhamaki on Friday, August 26, 2016
Friday, August 26, 2016
Managed to solve the problem, which was caused by missing auth cookie... However I think the seen error is not valid in this case as it didn't indicate any problem with authentication....
Tagged
Statistics
  • Started: 8/26/2016
  • Last Reply: 8/26/2016
  • Replies: 1
  • Views: 68
Powered by KronoDesk v1.1.0.15 | © Copyright Inflectra Corporation 2011-2016 | Licensed to Inflectra Corporation.