SpiraTest SOAP Webservice 5.0 Issue

Tuesday, December 5, 2017 9:18:40 PM

Good day. 

 

I'm attempting the following from Python

from suds.client import Client

client = Client("http://api.inflectra.com/Spira/Services/v5_0/SoapService.svc?wsdl")
testupdate = client.factory.create('TestCase_UpdateStep')
remoteTestStep = client.factory.create('RemoteTestStep')
        

 

When I print the testupdate object I get the following output: 

 

(TestCase_UpdateStep){
   remoteTestStep =
      (RemoteTestStep){
         ArtifactTypeId = None
         ConcurrencyDate = None
         CustomProperties =
            (ArrayOfRemoteArtifactCustomProperty){
               RemoteArtifactCustomProperty[] = <empty>
            }
         IsAttachments = None
         ProjectId = None
         Description = None
         ExecutionStatusId = None
         ExpectedResult = None
         LastUpdateDate = None
         LinkedTestCaseId = None
         Position = None
         SampleData = None
         TestCaseId = None
         TestStepId = None
      }
 }

 

But when the next line gets executed it returns the following error:

suds.TypeNotFound: Type not found: 'RemoteTestStep'

 

2 Replies
Friday, December 8, 2017 7:22:46 PM
Avatar
re: TennisonD on Tuesday, December 5, 2017 9:18:40 PM

Hi Tennison,

Unfortunately  we're not experts in Python / SUDS, but maybe this link will help:

https://stackoverflow.com/questions/4719854/soap-suds-and-the-dreaded-schema-type-not-found-error

Regards

Jim

Wednesday, December 20, 2017 3:46:08 PM
Avatar
re: inflectra.jimx on Friday, December 8, 2017

Hello. 

Thanks for your reply. I've tried that solution long before you suggested it and it still doesn't work. 

All indications point to their being an issue with the WSDL. Why is it I can use the WSDL to create a "TestCase_UpdateStep" object but the "RemoteTestStep" fails with "Type not found"? 

Statistics
  • Started: Tuesday, December 5, 2017 9:18:40 PM
  • Last Reply: Wednesday, December 20, 2017 3:46:09 PM
  • Replies: 2
  • Views: 807