Thread

Skip Navigation LinksForums > SpiraTest Forums > SpiraTest Issues & Questi... > Upgrade from v3.2 to v4.0...

Upgrade from v3.2 to v4.0 does not work with .NET 4.5 installed. RSS Feed

Thursday, March 21, 2013

I am trying to upgrade our installation of SpiraTest from v3.2 to v4.0. Everything seems to go well until at the very end of the installer is says that .NET Framework 4.0.30319 must be installed. Our server has been updated to .NET 4.5 (4.5.50709) which was required for other applications and it is my belief that it is backward compatible with .NET 4.0 applications.

How can I get around this issue?

1 Replies
Adam SAdam S
re: Dominic McKeown on Thursday, March 21, 2013
Saturday, March 23, 2013
There was an issue in the v3.2 installer that didn't correctly identity .NET 4.5 installations (so that it thought that v4.0 was not installed). This was fixed in the v4.0 installer, but because you are doing an update, the issue is that the part when it uninstalls v3.2 uses the older installer which does not have the fix.

If you open the following registry keys and locate the Version string and change it from 4.5.50709 to 4.0.30319 it will fake the installer into thinking that .NET 4.0 is installed. Once you are done, you can change it back.

SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Client
SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full

Tagged
Statistics
  • Started: 3/21/2013
  • Last Reply: 3/23/2013
  • Replies: 1
  • Views: 1018
Powered by KronoDesk v1.1.0.15 | © Copyright Inflectra Corporation 2011-2016 | Licensed to Inflectra Corporation.