Thread

Skip Navigation LinksForums > SpiraTest Forums > SpiraTest Issues & Questi... > Jira Integration

Jira Integration RSS Feed

Thursday, November 21, 2013
I have run into issues integrating Spiratest with Jira. We have the hosted service.

1. Downloaded and DesktopDataSync.exe and copied Jira dlls to the same folder. Made sure that the service is running (polling at 2 minutes interval)
2. Configured JiraDataSync->Project Mappings (Only mapped the fields under Incident artifact at this point)
3. Provided connection info (https://<jira server url>/rpc/soap/jirasoapservice-v2)  (confirmed that axis server was running); jira login/password (this account has admin access to Jira)
4. Confirmed that 'Accept remote API calls' is enabled in Jira.

It is still not working and I dont see any error message under Spiratest->Data synchronization. The Last Sync date is not even set, so that makes me think that Sync process didn't attempt to run. Am I missing anything?

Any help will be appreciated!
Thanks,
Nitesh

3 Replies
Nitesh AgarwalNitesh Agarwal
re: Nitesh Agarwal on Thursday, November 21, 2013
Thursday, November 21, 2013
After playing around with the configuration a little bit more, I can finally see some error message - 
The description for Event ID '0' in Source 'DesktopDataSync' cannot be found. The local computer may not have the necessary registry information or message DLL files to display the message, or you may not have permission to access them. The following information is part of the event:'General Error: Web Exception Error calling JIRA REST API: 'The remote server returned an error: (404) Not Found.' Details:

AXIS error


No service is available at this URL



at Inflectra.SpiraTest.PlugIns.Jira5DataSync.JiraClient.JiraManager.RunQuery(JiraResource resource, String argument, String data, String method)
at Inflectra.SpiraTest.PlugIns.Jira5DataSync.JiraClient.JiraManager.GetPermissions()
at Inflectra.SpiraTest.PlugIns.Jira5DataSync.DataSync.Execute(Nullable`1 lastSyncDate, DateTime serverDateTime)'

Does it mean that the connection info value is incorrect? It seems to work when I try it on the browser. This is what I see - 

jirasoapservice-v2

Hi there, this is an AXIS service!

Perhaps there will be a form for invoking the service here...
Adam SAdam S
re: Nitesh Agarwal on Thursday, November 21, 2013
Monday, November 25, 2013

Hi Nitesh

You are trying to use the SpiraTest JIRA 5+ plugin that uses the newer JIRA REST API with the URL for its older SOAP API. That is the reason why it's not connecting.

I shall provide more detailed information in the help desk ticket that you have logged.

Regards

Adam

Nitesh AgarwalNitesh Agarwal
re: Adam S on Monday, November 25, 2013
Monday, November 25, 2013
Thank you! Worked perfectly.
Tagged
jira
x 9
Statistics
  • Started: 11/21/2013
  • Last Reply: 11/26/2013
  • Replies: 3
  • Views: 1753
Powered by KronoDesk v1.1.0.15 | © Copyright Inflectra Corporation 2011-2016 | Licensed to Inflectra Corporation.