Objects not found on first run

Tuesday, August 5, 2014

I've got a weird issue going on with a script which is getting quite frustrating.  The script opens Chrome, navigates to a page and does a Global.DoWaitFor('Search');  It's waiting for the main search button to appear on the page so that I know the page has loaded.  After this it verifies the search button is enabled and that the text is correct. 

The issue I'm having is that the first time you run it you get an object not found error on the verification step.  If I then re-run the script leaving the previous failed chrome window open, the script successfully opens a new Chrome window, navigates to the page but this time finds the objects and passes.  This happens every time if starting from a point of no Chrome window open. I have tried adding in a Global.DoSleep and upped it to 15 seconds (15000), but still no luck on the first run.

Any ideas anyone?


4 Replies
Sunday, August 10, 2014
re: countdownSupport Tuesday, August 5, 2014
Hi Amanda

If you have not already done so, I'd recommend logging a help desk ticket since this is pretty specific.


Friday, July 31, 2015
re: inflectra.jimx Saturday, August 9, 2014

I am currently experiencing something similar. Sometimes elements that have been learned can be clicked on in order to progress further through the script and at other times the error "element does not appear on screen" is reported.
This is the case for several different elements. Is there a way to fix this?


Tuesday, February 18, 2020
re: l.goedschalk Friday, July 31, 2015


Is there any updates regarding this issue?


Friday, October 9, 2020
re: AGresola Monday, February 17, 2020

I think this issue was resolved long ago.

  • Started: Tuesday, August 5, 2014
  • Last Reply: Thursday, October 6, 2022
  • Replies: 4
  • Views: 12483