Split a task fails with Authorization failed

Wednesday, September 2, 2015
A user with the role Developer which has all permissions on tasks (Create, Modify all, Delete, View) tries to split a task, but received the message: System.ServiceModel.FaultException: Authorization failed.
We tried it with tasks with different Stati, Not Started, In Progress, Completed but always with the same result.
A user with the Manager role can doe this without problems.

What is the reason for the Authorization failure and how can we solve this for other roles than Manager?

Thank you.
1 Replies
Tuesday, September 8, 2015
re: KaiGerhold Wednesday, September 2, 2015
Hi Kai,

I checked into this, and unfortunately, it looks like there's a bug here. (I used the latest version, SpiraTeam For now, I'm afraid only manager and project owner roles are able to split tasks. I logged an incident. It will be fixed in an upcoming release. Thanks for letting us know!


Spira Helps You Deliver Quality Software, Faster and With Lower Risk

And if you have any questions, please email or call us at +1 (202) 558-6885


  • Started: Wednesday, September 2, 2015
  • Last Reply: Tuesday, September 8, 2015
  • Replies: 1
  • Views: 5713