gitlab plugin

Friday, October 26, 2018
Avatar

Hi There,

I'm having no end of bother trying to get the gitlab plugin to work!

We have a locally hosted Spirateam (5.4.0.1) instance, along with a locally hosted Gitlab (11.4.0 (6ebbd70)) instance. I have configured as per the guide, but I just cannot get it working! Constantly throwing the following error:

```

General Error: The remote server returned an error: (404) Not Found.
   at System.Net.HttpWebRequest.GetResponse()
   at GitLabDataSync.InternalFunctions.httpGET(String url, String password)
   at GitLabDataSync.InternalFunctions.getMilestones(String externalProject, DataSync sync)
   at GitLabDataSync.DataSync.Execute(Nullable`1 lastSyncDate, DateTime serverDateTime)

```

 

The Gitlab user that we have configured has access to the project that we're attempting to set up, and the spira user has project access to everything.

 

I've tried to set the `TraceLogging` value to `True` in the `DataSyncService.exe.config` to see if it would give me more detailed info, but alas no!

 

Any help or pointers would be greatly appreciated. 

 

Cheers

 

Adam

2 Replies
Friday, October 26, 2018
Avatar
re: awarner Friday, October 26, 2018

Actually, going to open this as a support ticket. 

 

Cheers

Friday, October 26, 2018
Avatar
re: awarner Friday, October 26, 2018

Hi Adam,

yes please log a help desk ticket, it will be easier to solve this kind of issue that way since we may need sensitive (non-public) information to assist.

Regards

Jim

Statistics
  • Started: Friday, October 26, 2018
  • Last Reply: Friday, October 26, 2018
  • Replies: 2
  • Views: 276