Skip Navigation LinksForums > Integrations & Plug-Ins > Data Importers > Priority and Status data ...

Priority and Status data not importing from Contour? RSS Feed

Sunday, December 4, 2011
Hi - we're currently looking at using Jama Contour to manage/develop requirements and are testing the import tool to see how we can integrate it with SpiraTest - Is there a trick to getting the priority and status data to import along with the requirements from contour? The requirements are coming across fine, but the rest of the data isn't... not sure if it's a version thing (we're only using v3.0 of SpiraTest, running the latest version of contour - but as a 14-day trial installation). The import doc clearly shows the mappings that are supposed to happen, it just doesn't seem to work for us.

Also, if we change a requirement in Contour and re-import, the changes are reflected and the change history is updated, but it appears that unchanged requirements are also reimported (last modified date is updated for all requirements) - is this supposed to happen? How do I get a report in SpiraTest on requirements that have been changed?

Just wanted to see if this has come up before and anyone has any info on it all (can't update SpiraTest to v3.1 and test again for a few weeks while other testing is going on).

6 Replies
Adam SAdam S
re: Martin J on Sunday, December 4, 2011
Tuesday, December 6, 2011
What version of Jama Contour are you using? Their API is very unstable and we found that we had to update the importer each time they updated Contour since their SOAP API definition could often result in data not being accessible to the importer.
Martin JMartin J
re: Adam S on Tuesday, December 6, 2011
Tuesday, December 6, 2011
Yeah, looks like they've recently made a reasonably significant upgrade to Contour - we're running the current version which appears to be 3.3.1 which they just released Nov 21st (I'll confirm that next time I check in, not sure if there are any further point releases after that).
Martin JMartin J
re: Martin J on Tuesday, December 6, 2011
Thursday, December 8, 2011
Yeah, the current build of contour we're using is 3.3.1 b20762 (22nd Nov 2011)
Adam SAdam S
re: Martin J on Thursday, December 8, 2011
Wednesday, December 14, 2011
Is it possible to ask Jama for a copy of the WSDL file for the latest version (they'll know what this is) so that we can recompile the importer against it. Please send the file to and we'll update the importer. They don't properly version the API, making this necessary.
Martin JMartin J
re: Adam S on Wednesday, December 14, 2011
Thursday, December 15, 2011
I've sent the request through to Jama, but it appears that it may be an issue on their end, the reply I got back is that it is a known issue with 3.3.1 and they are currently working on a patch, due out early next week - so hopefully that will fix the issue :)
Adam SAdam S
re: Martin J on Thursday, December 15, 2011
Monday, December 19, 2011
OK, thanks for letting us know!
  • Started: 12/4/2011
  • Last Reply: 12/19/2011
  • Replies: 6
  • Views: 5201
Powered by KronoDesk v1.1.0.15 | © Copyright Inflectra Corporation 2011-2016 | Licensed to Inflectra Corporation.