Thread

Skip Navigation LinksForums > SpiraTeam Forums > SpiraTeam Issues & Questi... > Different Spira SOAP API ...

Different Spira SOAP API than described in the online manual. RSS Feed

Friday, October 3, 2014

We would like to use the Spira SOAP API to automate some tasks. Today, I found that the online manual (http://www.inflectra.com/SpiraDemo3/Services/v4_0/ImportExport.aspx) describes more features than our local hosted Spira Server.

Two funtions we are interested in are: Requirement_Indent ( ... ) and Requirement_Outdent ( ... ). In our local server's wsdl file does not contain these functions, while the online example does. So I thought to link (from Visual Studio) to the online example's wsdl file. Now, I have the functions. But when I try to run them, I get an error that:
The message with Action 'http://www.inflectra.com/SpiraTest/Services/v4.0/IImportExport/Requirement_Outdent' cannot be processed at the receiver, due to a ContractFilter mismatch at the EndpointDispatcher. This may be because of either a contract mismatch (mismatched Actions between sender and receiver) or a binding/security mismatch between the sender and the receiver.  Check that sender and receiver have the same contract and the same binding (including security requirements, e.g. Message, Transport, None).

How can we force the SOAP API to be updated to the latest standards?

P.S. I do not have direct access to the server myself, but I am an Spira Admin.

 

 

2 Replies
Stefan van LoenhoutStefan van Loenhout
re: Stefan van Loenhout on Friday, October 3, 2014
Friday, October 3, 2014

Under de documentation, I found some release notes for Spira v4.2: http://www.inflectra.com/SpiraTeam/Documentation.aspx

One of the enhancements are:

  • Additional functions added to both the SOAP and REST web service APIs .

So, probably it is a new feature. Is there a list of all SOAP functions that are new in Spira v4.2? This may impact our update plans ;-)

 

 

 

 

 

 

 

 

 

 

 

 

Elise B.Elise B.
re: Stefan van Loenhout on Friday, October 3, 2014
Friday, October 3, 2014
Hi Stefan,

Yes, you're correct -- the SOAP API was just updated, and you'll need SpiraTeam 4.2 in order to use the new Requirement Indent and Outdent functions. I checked with development, and they said those are the only two functions that were added.

Regards,
Elise
Tagged
Statistics
  • Started: 10/3/2014
  • Last Reply: 10/3/2014
  • Replies: 2
  • Views: 392
Powered by KronoDesk v1.1.0.15 | © Copyright Inflectra Corporation 2011-2016 | Licensed to Inflectra Corporation.