Skip Navigation LinksForums > SpiraTeam Forums > SpiraTeam Issues & Questi... > Spira Team execution stat...

Spira Team execution status is not updated for some test cases while execution a Test Set(list of Test Cases) RSS Feed

Thursday, February 5, 2015

Background: We are using Command line engine as Automation engine in Remote Launch.

Problem Statement: Even after successful test case execution, for some cases the Execution Status in the SpiraTeam is not updated.

Whereas the Test Results show output results as success for the same test case.

Could you please let us know how to resolve this issue.?
Is there any pre-required bandwidth with which Test cases will be updated 100%.?

5 Replies
Jim R.Jim R.
re: preethi M on Thursday, February 5, 2015
Friday, February 6, 2015
Hi Preethi

Please can you submit a help desk ticket and our team will investigate for you.
This is too specific for us to resolve in the forums.

martin alavimartin alavi
re: Jim R. on Friday, February 6, 2015
Monday, February 8, 2016
Was there a fix for this?

I am seeing the same problem.

Tests have been passed but the execution status lists them as not run.
Elise B.Elise B.
re: martin alavi on Monday, February 8, 2016
Monday, February 8, 2016
Hi Martin,

There wasn't a simple solution, so it's best for you to log a Help Desk ticket. There are several possibilities as to why the test case may be showing up as 'Not Run' so we will need more information to help get to the root cause. When you log the ticket, please include the following:

The script that is being executed by RemoteLaunch will most likely output something back to the console output. That would be parsed by RemoteLaunch to determine if it passed/failed or was not run. Could you provide an example of the console output for that script when it is reporting back as Not Run?

Also can you go to RemoteLaunch, click on the 'Command Line' extension tab and send us a screenshot of the settings? Thanks.



martin alavimartin alavi
re: Elise B. on Monday, February 8, 2016
Tuesday, February 9, 2016
Hi Elise.

Thanks for coming back to me.

Ours is actually a much simpler case as it is just a manual test run. NO automation involved at all.

I have tried to use the data tools to correct the test status but it gets half way on the progress bar and then doesn't go any further.

When we look at the test set progress bar it says half of the tests have been run but when we open the test set all of the test cases have actually been run.
Elise B.Elise B.
re: martin alavi on Tuesday, February 9, 2016
Tuesday, February 9, 2016
Hi Martin,

Oh, the original question was about Remote Launch. If you are doing manual testing, that's completely different.

You're saying that all of the individual test cases in a particular test set have been executed, but when you view the main test set list, the progress bar only shows about half green?

The most-likely explanation is that some of the test cases were executed independently of the test set. Their execution status only affects the test set progress if they were executed as part of the test set. To check that, open the test set and look at the test run tab. That shows you all of the test run details.

You said "I have tried to use the data tools to correct the test status but it gets half way on the progress bar and then doesn't go any further.I'm not sure what you mean. Can you provide more details?

This is getting a bit too detailed for the forum, I think. So I recommend that you log a Help Desk ticket.


  • Started: 2/5/2015
  • Last Reply: 2/9/2016
  • Replies: 5
  • Views: 435
Powered by KronoDesk v1.1.0.15 | © Copyright Inflectra Corporation 2011-2016 | Licensed to Inflectra Corporation.