Thread

Skip Navigation LinksForums > SpiraTeam Forums > SpiraTeam Issues & Questi... > The session was not authe...

The session was not authenticated RSS Feed

Friday, August 26, 2016
Hi Team,

 I am getting the below exception while importing the 10GB size project, from HP QC to SpiraTeam.
*ERROR* Occurred during Import: 'The session was not authenticated, please call the Connection_Authenticate() method first' at mscorlib (
Server stack trace: 
   at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc)
   at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
   at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs)
   at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
   at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

My app.config is 


<bindings>
              <basicHttpBinding>
                    <binding name="BasicHttpBinding_IImportExport" closeTimeout="00:01:00"
                          openTimeout="00:10:00" receiveTimeout="00:10:00" sendTimeout="00:10:00"
                          allowCookies="true" bypassProxyOnLocal="false" hostNameComparisonMode="StrongWildcard"
                          maxBufferPoolSize="2147483647" maxBufferSize="2147483647"
                          maxReceivedMessageSize="2147483647" textEncoding="utf-8"
                          transferMode="Buffered" useDefaultWebProxy="true" messageEncoding="Text">
                          <readerQuotas maxDepth="2147483647" maxStringContentLength="2147483647"
                                maxArrayLength="2147483647" maxBytesPerRead="2147483647"
                                maxNameTableCharCount="2147483647" />
                          <security mode="None">
                                <transport clientCredentialType="None" proxyCredentialType="None"
                                      realm="" />
                                <message clientCredentialType="UserName" algorithmSuite="Default" />
                          </security>
                    </binding>
              </basicHttpBinding>
        </bindings>

Thanks,
Venkat.
1 Replies
Adam SAdam S
re: venkat s chinna on Friday, August 26, 2016
Monday, August 29, 2016
Hi Venkat

That means the SpiraTeam session expired during the import. Typically there are several possible causes:
  • You are using a load balancer with ASP.NET session routing not enabled
  • You have the IIS application pool set to recycle during the import period
  • Someone logged in and out of Spira using the same credentials as the importer
  • You are running multiple imports at once using the same credentials

Regards

Adam

Tagged
Statistics
  • Started: 8/26/2016
  • Last Reply: 8/29/2016
  • Replies: 1
  • Views: 140
Powered by KronoDesk v1.1.0.15 | © Copyright Inflectra Corporation 2011-2016 | Licensed to Inflectra Corporation.