Updated Eclipse Juno Mylyn connector?

Thursday, February 7, 2013 3:50:59 PM

I'm trying to install the Mylyn connector for Eclipse Juno, keep getting the following error:

Cannot complete the install because one or more required items could not be found.
  Software being installed: SpiraTeam Feature 3.0.0.201205071237 (com.inflectra.spirateam.mylyn.feature.feature.group 3.0.0.201205071237)
  Missing requirement: com.inflectra.spirateam.mylyn.ui 3.0.0.201205071237 requires 'package org.eclipse.mylyn.internal.provisional.commons.ui 0.0.0' but it could not be found
  Cannot satisfy dependency:
    From: SpiraTeam Feature 3.0.0.201205071237 (com.inflectra.spirateam.mylyn.feature.feature.group 3.0.0.201205071237)
    To: com.inflectra.spirateam.mylyn.ui [3.0.0.201205071237]

From the Eclipse website it looks like the package that it's looking for may have changed:

org.eclipse.mylyn.internal.provisional.commons.core        -> org.eclipse.mylyn.commons.core
org.eclipse.mylyn.internal.provisional.commons.ui          -> org.eclipse.mylyn.commons.ui
                                                           -> org.eclipse.mylyn.commons.workbench
                                                           -> org.eclipse.mylyn.commons.workbench.browser
                                                           -> org.eclipse.mylyn.commons.workbench.editors
                                                           -> org.eclipse.mylyn.commons.workbench.forms
                                                           -> org.eclipse.mylyn.commons.workbench.search
org.eclipse.mylyn.internal.provisional.commons.ui.actions  -> org.eclipse.mylyn.commons.ui
org.eclipse.mylyn.internal.provisional.commons.ui.commands -> org.eclipse.mylyn.commons.workbench.texteditor
org.eclipse.mylyn.internal.provisional.commons.ui.dialogs  -> org.eclipse.mylyn.commons.ui.dialogs
org.eclipse.mylyn.internal.provisional.commons.ui.editor   -> org.eclipse.mylyn.commons.workbench
 
Is it possible to get an updated connector (or do you know if there's a way to install the old packages in Eclipse?
2 Replies
Friday, February 8, 2013 11:59:45 AM
Avatar
re: jferencak on Thursday, February 7, 2013 3:50:59 PM

To use the current version you'd need to install the older version of Mylyn from Eclipse.

Now that Spira 4.0 has been released, we are working to update the Mylyn connector to use the newer Spira 4.0 API and custom properties and also the newer Mylyn libraries.

Saturday, May 11, 2013 11:42:43 AM
Avatar
re: inflectra.adam on Friday, February 8, 2013

We have just released the Eclipse 3.8+ and SpiraTeam 4.0+ compatible version of the Mylyn plugin.

Please download the latest version from https://www.inflectra.com/Downloads/Eclipse and try again.

Regards

Adam

Statistics
  • Started: Thursday, February 7, 2013 3:50:59 PM
  • Last Reply: Saturday, May 11, 2013 11:42:43 AM
  • Replies: 2
  • Views: 1194