Thread

Skip Navigation LinksForums > SpiraTest Forums > SpiraTest Issues & Questi... > New requirements being de...

New requirements being defaulted to Planned RSS Feed

Tuesday, June 26, 2012

We have seen that when creating a requirement, when we create the requirement on any defined release, the Status changes to Planned.  I'm assuming this is a workflow step created to say that the status should always be planned when it is assoicated with a release.  Is there any way we can change this?  We would like to track our test planning process with this Status field, and we have the requirements associated with releases before we start this planning, so it would be nice if we could not default to that planned status when creating the requirements.  Any suggestions would be great.  Thanks!

4 Replies
Adam SAdam S
re: Brett Barker on Tuesday, June 26, 2012
Friday, June 29, 2012
Brett Barker

when we assign the requirement on any defined release, the Status changes to Planned.  I'm assuming this is a workflow step created to say that the status should always be planned when it is assoicated with a release. 

Unfortunately that is not configurable in the current version. You'd need to either just switch it back from Planned to some other status manually or use a custom property to track it in a different custom status.

Hugh StitelerHugh Stiteler
re: Adam S on Friday, June 29, 2012
Thursday, September 3, 2015
I'm having the same issue. Your workaround to "just switch it back from Planned to some other status manually" is not a good one, as it makes the release filed blank. This is really a hindrance and should be addressed. I'm using v4.2.0.5.
Elise B.Elise B.
re: Hugh Stiteler on Thursday, September 3, 2015
Tuesday, September 8, 2015
Hi Hugh,

Not to worry, that reply from Adam is out-of-date. There have been major changes to the requirement functionality since then! Configurable workflow was introduced for requirements, which allows you to customize the status changes, including permissions and field statuses (required, hidden, disabled). Some automatic changes were kept in effect, but there are now flags for them, so that they can be turned off, if needed.

Specifically, go to Administration -> Planning -> Planning Options. Then uncheck the Auto-Planned option. 

That should do the trick!

Regards,
Elise
Hugh StitelerHugh Stiteler
re: Elise B. on Tuesday, September 8, 2015
Tuesday, September 8, 2015
That did the trick! Thanks for the tip.
Tagged
Statistics
  • Started: 6/26/2012
  • Last Reply: 9/8/2015
  • Replies: 4
  • Views: 663
Powered by KronoDesk v1.1.0.15 | © Copyright Inflectra Corporation 2011-2016 | Licensed to Inflectra Corporation.