Thread

Skip Navigation LinksForums > SpiraTest Forums > SpiraTest Issues & Questi... > Disabled custom propertie...

Disabled custom properties disabled in Workflow not enforced in list view RSS Feed

Thursday, June 26, 2014
I have several custom properties that I created for requirements. I have disabled some of these fields for certain workflow steps. If I open the requirement that is in that current status the fields are disabled. However, in the list view I am able to change those disabled fields with no restrictions. How do I disable fields in the list view?
4 Replies
Rajesh BeeraRajesh Beera
re: Hugh Stiteler on Thursday, June 26, 2014
Monday, June 30, 2014
You Should be able to hide the custom fields from the workflow steps.
Hugh StitelerHugh Stiteler
re: Rajesh Beera on Monday, June 30, 2014
Monday, June 30, 2014
Thanks, Rajesh, but even with them hidden I can change the fields in list view as they still appear.
Rajesh BeeraRajesh Beera
re: Hugh Stiteler on Monday, June 30, 2014
Monday, June 30, 2014
Spira Test doesn't work that well on all browsers. Chrome is better option of all the browsers or at least i think it is.
Once you have hidden those fields try to log out and re login to see if that makes them disappear from the view.
Elise B.Elise B.
re: Hugh Stiteler on Thursday, June 26, 2014
Tuesday, July 1, 2014
Hi Hugh,

That's true - the workflow is only enforced in the detail view, not the list view. What you can do is disallow some roles from making any edits in the list view. Under Administration -> Users -> View/Edit Roles, in the "Artifact Permissions" section, DEselect "Modify All". This is the option that allows editing on the list view. Then select "Modify Owned" instead; this option allows editing on detail pages.

Regards,
Elise
Tagged
Statistics
  • Started: 6/26/2014
  • Last Reply: 7/1/2014
  • Replies: 4
  • Views: 554
Powered by KronoDesk v1.1.0.15 | © Copyright Inflectra Corporation 2011-2016 | Licensed to Inflectra Corporation.