New Spira - Jira plugin announced 27-Feb-2017.

Tuesday, March 28, 2017


I read the article about the New Spira - Jira plugin with the new function of synchronizing requerments.

The IT section at my firm say that the Version 4.0.0 is Version they already have installed. so is the announced plugin in the article Version 4.0.0.? Or is this not the updated one?

We have the possibility to use custom Field 04 to get requirments synced, but they all sync as the same type: "Feature".  We use different types of requirments, so a Use Story and a Use Case is synced as "Feature". Do we have to make changes to a xml file.? Or is there a easyer way.. Ive testet around with the Edit Standard Field Data Mapping, and put the right keys there, but the same keys are used in customfield 04.



7 Replies
Wednesday, March 29, 2017
re: MarisuA Tuesday, March 28, 2017

Some bad explaining on my side.. 


Part one:

In the download section on inflectra site, there is a plugin for jira-spira integration. The version states: 4.0.0.

In the article inflectra posted 27 feb, it stated that the jira-spira plugin was been updated, with new functionality like syncing requerments from jira to spira. 

The manager at my firm said that we already had the 4.0.0 version of the jira-spira plugin (we got it last year). So the question is: do we maybe have a beta version of 4.0.0 or isn't the 4.0.0 on the inflectra download site updated (like the article stated)?


Part two:

We have tried the Custom 4 field to sync requirements from Jira to spira, it is syncing but, they all get the same type "Feature" in Spira, regardless of the type it had in Jira.
So we tired to use the Custom 4 field with multiple values, like 18 (User Stories) and 8 (Use Cases). But they all get changed to "Feature". 

We also been in the "Edit Standard Field Data Mapping" under Artifact Type "Requirement" and Type and tried to use the same values as typen inn at custom 4. (ex. Custom 4 = 18,9) and (ex. Requirement -> Type -> Use Case = 9 and User Story = 18). But when we add the same values from Custom 4 inn edit standard field data mapping, nothing is beeing synced.

Thursday, March 30, 2017
re: MarisuA Wednesday, March 29, 2017

Hi Marius

Sorry for any confusion. The version of the JIRA plugin on our website is now actually v5.0.

We have updated the website to make this clear.

This new version simply uses the Requirements - Status mapping in the data-synchronization UI, no other configuration changes are needed.



Monday, April 3, 2017
re: inflectra.jimx Thursday, March 30, 2017

Thanks for the info.

Do you have an example of how we can sync requirments from Jira to Spiratest?


We want to sync the requirments :User Stories  and Use Cases from Jira to Spiratest.

The User Stories have in Jira keyID  = 18

The Use Cases have in Jira keyID = 9

How do i set this up in Spiratest? The user manual doesnt specify  how this is done in a good and understanding way.

Monday, April 3, 2017
re: MarisuA Monday, April 3, 2017

Hi Marius,


The instructions for configuring the requirement type synchronization are in the manual, specifically pages 20-21. Have you seen that?

If you are having trouble getting it to work, please create a Help Desk ticket.




Tuesday, April 4, 2017
re: inflectra.kat Monday, April 3, 2017
I have read the instructions, but have problems with it. It seems its missing something.
I have some examples:
1. Following the manual text in it for syncing requirments from Jira to Spira on page 19 to 21.
We use the following config:
- Custom 04 was set to blank.
(Under View Project Mappings -> Requirments -> Type):
- Use Case = 9
- User Story = 18
When trying to sync with this configuration nothing is beeing synced from JIRA to Spira.
2. Following the pictures from page 19 (top picture) and page 21 (top picture).
We used the following configuration:
- Custom 04 = 9,18
(Under View Project Mappings -> Requirments -> Type):
- Use Case = 9
- User Story = 18
This configuration do get the requirments synced but, the requirments (9,18) is synced as "FEATURE", regardless of the values that is used under
"View Project Mappings -> Requirments -> Type".
Is this a bug/limitation in the Spiratest 5.1 or the Jira integration v5.0.0.?
Or are we doing somthing wrong.?
Everything else, like Incidents are syncing correct by using the "Incidents-> Types" under "View Project Mappings" and nothing in the custom Fields.
Tuesday, April 4, 2017
re: MarisuA Tuesday, April 4, 2017

Did some more testing / investigating and found the example 2  that synced the requirments as "FEATURE" regardless of the value in "View Project Mappings -> Requirments -> Type" needs a double sync to set the type correct.
The first sync, synchronizes all requirments set by the Custom 04 section, the second time spiratest synchronizes it uses the configurated values from "View Project Mappings -> Requirments -> Type" and sets the correct type.

Why does it need 2 synchronizations to set det correct type from Jira? The Incidents gets the correct type the first time.


Tuesday, April 4, 2017
re: MarisuA Tuesday, April 4, 2017

Hi Marius,


Could you please create a Help Desk ticket? We can give you more specific assistance that way.




Spira Helps You Deliver Quality Software, Faster and With Lower Risk

And if you have any questions, please email or call us at +1 (202) 558-6885


  • Started: Tuesday, March 28, 2017
  • Last Reply: Tuesday, April 4, 2017
  • Replies: 7
  • Views: 9755